要与这本书一起进行,您需要以下内容:

  • Mac运行 麦斯莫斯莫哈韦斯 (10.14.4)或更高版本。可选地,您可以使用 麦斯卡洛丽娜 (10.15).

  • Xcode 11或更高版本。 Xcode是iOS的主要开发工具。您将需要Xcode 11或更高版本来使用Swifui。您可以在此处从Apple开发人员网站下载最新版本的Xcode: Apple.co/2asi58y..

笔记:本书中所涵盖的代码由Swift 5.2,MacOS Catalina和Xcode 11.5开发和测试 - 因此,即使您可以使用略微早期的版本,我们建议您更新到这些版本,以便在没有意外错误的情况下遵循这本书。

有一个技术问题?想报告一个错误吗? 您可以向官方书籍论坛中的书籍作者提出问题和报告错误 这里.

有反馈分享在线阅读体验吗? 如果您有关于UI,UX,突出显示或我们在线阅读器的其他功能的反馈,您可以将其发送到设计团队,其中表格如下所示:

© 2021 Razeware LLC