首页 扑腾书籍 扑腾学徒

i
你需要什么

要与这本书一起进行,您需要以下内容:

  • Xcode 12.2或更高版本。 Xcode是iOS的主要开发工具,需要为iOS构建浮动应用程序。您可以在此处从Apple开发人员网站下载最新版本的Xcode: Apple.co/2asi58y.,或来自Mac App Store。 Xcode 12.2需要Mac运行 MacOS Catalina(10.15)或更高版本.

    笔记:您还可以选择使用Linux或Windows,但您将无法在这些平台上安装Xcode或为iOS构建应用程序。

    笔记:从2021年4月开始,Apple将要求提交给App Store的应用程序使用 MacOS Catalina(10.15)或更高版本Xcode 12或更高版本 与之 iOS 14 SDK..

  • Flutter SDK 1.22.6或更高版本 。您可以从官方浮动网站下载扑颤SDK //flutter.dev/docs/get-started/install/macos。安装Flutter SDK也将安装 飞镖SDK.,您需要在浮动应用程序中编译飞镖码。

  • Android Studio 4.1.2或更高版本,可用 //developer.android.com/studio。这是您在本书中开发示例代码的IDE。它还包括Android SDK和用于在Android上运行Flutter应用程序的构建系统。

  • Android Studio V53.1.1或更高版本的浮动插件,通过前往Android Studio安装 优先 在麦斯斯(或 设置 在Windows / Linux上)和选择 插件,然后搜索“flutter”。

您还可以选择使用 Visual Studio Code. 对于您的浮动开发环境而不是Android Studio。您仍然需要安装Android Studio才能访问Android SDK和Android仿真器。如果您选择使用Visual Studio代码,请按照官方扑波网站上的说明进行操作 //flutter.dev/docs/get-started/editor?tab=vscode to get set up.

第1章:“入门”将更多地解释扑振历史和架构。您将学习如何使用Flutter SDK开始。然后,您将看到如何使用Android Studio和Xcode来构建和运行Flutter应用程序。

有一个技术问题?想报告一个错误吗? 您可以向官方书籍论坛中的书籍作者提出问题和报告错误 这里.

有反馈分享在线阅读体验吗? 如果您有关于UI,UX,突出显示或我们在线阅读器的其他功能的反馈,您可以将其发送到设计团队,其中表格如下所示:

© 2021 Razeware LLC